You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 314 guest(s) and 17 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - Blocks-Cannot edit-save changes HELP PLEASE!!! [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Fri Mar 23, 2007 12:06 pm Reply with quoteBack to top

I am desperate here and really need help.

After my host migrated my database to sql5, I have not been able to edit any blocks on the home page. I can add a block (no html will save tho) but after I add one I cannot edit it. I can edit and save it if it is in "content" like FAQ etc but a block with just content on home page with basic info or banners it will not save.

When I edit it and update before I save it shows perfect but after I hit save its gone.

I have run tests, analyzers, tried to get an error message and nothing ..

I have found maybe 3 posts on the internet about this and it seems to come up with upgrades but not one shows the fix for this and I know there has to be one. This happens with different versions of phpnuke and in my case i didnt upgrade nuke, my host upgraded sql

I have spent 4 days, 15 hours a day researching this and trying anything and everything and nothing works...

PLEASE HELP !!!!

DD
Find all posts by DiamondsDebView user's profileSend private message
v3x
Support Mod
Support Mod


Joined: Oct 19, 2004
Posts: 1041

Location: UK

PostPosted: Fri Mar 23, 2007 11:38 pm Reply with quoteBack to top

It sounds to me like your database has become corrupted somewhere.

Have you tried repairing it?

What version are you running? patched?
Find all posts by v3xView user's profileSend private messageVisit poster's website
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Fri Mar 23, 2007 11:50 pm Reply with quoteBack to top

I am on ver 7.7 with 3.1 patch.

I have tried running repair on certain tables but not the entire database.

What is strange is that I also have a test site setup almost identical and when they moved that to sql5 it has the same problem.

What I don't understand is that I have seen a few posts with different versions of Nuke and they had the same problem but no one ever posted how they fixed it. Some were upgrade Nuke some just patching it and of course some moving to sql5.

I also discovered that I cannot post to the calendar either and there they give me "DB error: unknown error".

Also as I stated is it shows the edit correctly until you click save.

I am at a loss and I have been working on this for so long now, I have run out of things to try.

DD
Find all posts by DiamondsDebView user's profileSend private message
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Sat Mar 24, 2007 12:05 am Reply with quoteBack to top

I just tried a repair on entire database. Everything checks out EXCEPT ...

it seems they have change the database type(engine) on some of the files from MyISAM to InnoDB... Rolling Eyes I get a message that these files do not support the "repair" function...

Why these are like this I have no clue. I have read some on this but cannot find enough on PHP Nuke and InnoDB.

I had asked my host why and I have not gotten a response. The last response I got from them I won't repeat. They do not want to take any responsibility for screwing up my database files. I don't know if I can go in and change it back without making it worse....or if it even makes a difference.

Any help here would be greatly appreciated...

Signed
Desperate
Find all posts by DiamondsDebView user's profileSend private message
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Sat Mar 24, 2007 12:34 am Reply with quoteBack to top

Okay I decided to go ahead and change the "type" on the ones that were InnoDB on the test site (figured I couldnt do much more damange)..

I changed them and then repaired the entire database again and everything is "OK" according to the repair...

But of course if I go to try and edit a block...it wont save it and I tried the calendar again since they were most of the files that had the InnoDB change and still get the same error "DB error: unknown error"..

Now that it is almost morning I am going to get some sleep ...
and this is actual early for me compared to the last four nights...

Please HELP !!!

DD
Find all posts by DiamondsDebView user's profileSend private message
v3x
Support Mod
Support Mod


Joined: Oct 19, 2004
Posts: 1041

Location: UK

PostPosted: Sat Mar 24, 2007 6:57 am Reply with quoteBack to top

Advice: Change your hosting to mine and I'll find the problem and repair it for free!

That may not be much constructive help but its going to take more of a detailed analysis, which I would suggest, is going to make a fix very difficult to determine through the forums.
Find all posts by v3xView user's profileSend private messageVisit poster's website
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Sat Mar 24, 2007 12:35 pm Reply with quoteBack to top

What version of phpNuke are you using? Any addons or mods?

Post the structure of your blocks module here

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Sat Mar 24, 2007 1:42 pm Reply with quoteBack to top

Hi Evaders...

Nuke ver 7.7 with patch 3.1 (which by the way you did) Very Happy

I just tried to add you back as an admin and it won't let me. It gives me a blank screen. It will let me edit admin but not add.

Today I went on the test site and deactivated all add ons and blocks and added a new block and then tried to edit and nothing...

I reactivated Center 4 blocks and for some reason that one I can edit...

Remember everything was fine till they migrated the database to sql5

Also I just requested from the host to see if I could set up a test site outside of this one and I want to take an old backup of site and database and try and restore but since they havent answered my last two messages I dont see that happening

Here is a pic of the nuke_block and admin page blocks though not all are active:

Image

Image

If you want to go in and look at the mess, let me know and I will PM you the logins...

Thanks
DD

PS: site is www.pokervoyeurs.com (that should sound familiar..lol)
Find all posts by DiamondsDebView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Sat Mar 24, 2007 9:20 pm Reply with quoteBack to top

Ah yes I do remember.
The blocks table does seem correct.

I'll be happy to look into it, just send me the logins.

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Sat Mar 24, 2007 10:57 pm Reply with quoteBack to top

Thanks Evaders...

I have requested they move me back to the old sql server. I don't know if this will happen in the morning or not. I will wait and see before I send you the logins so you go to the right place.

I only will have the old server for a few weeks before I either have to upgrade nuke or find a new host..lol

Either way I am going to have these problems I am sure. I am guessing also moving the database back to the old server is not going to fix this unless I restore an old backup...

I am brain dead now but I will send you both logins and urls for new and old server in the morning.

Thanks so much I was ready to shoot myself or them... Rolling Eyes I still might. I have so much work into this site, its not an option to lose it now.

DD
Find all posts by DiamondsDebView user's profileSend private message
DiamondsDeb
Nuke Soldier
Nuke Soldier


Joined: Nov 27, 2006
Posts: 13


PostPosted: Sun Mar 25, 2007 9:11 am Reply with quoteBack to top

Login info sent...

Here is the latest ...now this is weird...of course all of this is weird since it was perfect before the move to sql5

I went to try and add a new admin but this time I was adding a superuser and not just certain permissions and it added it just fine. So I thought a miracle it fixed itself....rofl So I tried to add admin with just certain permissions...and no luck...back to white page... Crying or Very sad

Now I do not know the full structure of how all this works (though I know more now) but that just makes absolutely no sense to me...

Thanks Evaders for taking a look. I sure hope you can find the problem (s)

I have not heard from them yet about moving back to sql4 and lately they take longer and longer to answer my open tickets...

DD
Find all posts by DiamondsDebView user's profileSend private message
KOC2000
Nuke Cadet
Nuke Cadet


Joined: Nov 27, 2007
Posts: 1


PostPosted: Tue Nov 27, 2007 1:30 am Reply with quoteBack to top

I've the same problem with phpnuke 8.0 and 8.1, cannot edit/save blocks, I wish someone can help me out..
Find all posts by KOC2000View user's profileSend private message
i002399
Nuke Soldier
Nuke Soldier


Joined: Dec 08, 2003
Posts: 10


PostPosted: Tue Jan 01, 2008 11:19 am Reply with quoteBack to top

i have the same problem. after upgrading to 7.6 the block edit features dont work.

old nuke had us edit text fields, but now we're using a rich-text editor. somehow the saves arent working. the activation/deactivate works fine, but cannot edit the block's content and save. pretty strange.
Find all posts by i002399View user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Tue Jan 01, 2008 8:10 pm Reply with quoteBack to top

Post the structure of your nuke_blocks table please

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
i002399
Nuke Soldier
Nuke Soldier


Joined: Dec 08, 2003
Posts: 10


PostPosted: Fri Jan 04, 2008 12:23 pm Reply with quoteBack to top

my nuke blocks table is identical to the one posted above from the other user.

i'm wondering if one of the upgrade scripts didnt run correctly or something. I'm upgrading from 6.5 to 7.6 (ravennuke distribution). would any of the raven migration steps kill the private messages or ability to post content?

message boards work fine, but PM's are dead and i cannot change any HTML Block.

anyone else run into this?
Find all posts by i002399View user's profileSend private message
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.100 Seconds - 427 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::