You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 191 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - upgrade from 7.5 [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
moods
Corporal
Corporal


Joined: Dec 13, 2005
Posts: 72


PostPosted: Fri May 26, 2006 8:36 am Reply with quoteBack to top

i am using phpnuke 7.5 and new to phpnuke
can someone help me. my queries:

1.how do i upgrade to a higher version.
2. i want to upgrade for better security. which version should i upgrade?
3. while upgrading will the data in my site be intact?
Find all posts by moodsView user's profileSend private message
dezina
Support Mod
Support Mod


Joined: Jun 09, 2003
Posts: 1713

Location: England

PostPosted: Sun May 28, 2006 9:22 am Reply with quoteBack to top

Read my signature then visit
http://64bit.us/article83.html
If you need to upgrade, best version is
from http://ravenphpscripts.com/
i.e. RavenNuke76(tm) Version 2.02.02!

_________________
Image
Backup files BEFORE altering
Use PHPNuke 7.6 with patches!!
No private messages please, POST in forums.
Find all posts by dezinaView user's profileSend private messageVisit poster's website
thewall
Nuke Cadet
Nuke Cadet


Joined: Apr 25, 2006
Posts: 4


PostPosted: Wed Nov 29, 2006 9:44 am Reply with quoteBack to top

I'm not the OP...but I have an issue with upgrading from 7.5 so I posted in this thread.

I upgraded from 7.5 to 7.9 over the weekend (yeah, who does such a thing on the holiday weekend anyways)...

Everything is working EXCEPT for the forums. I turned on debugging and I get the following error when I access forums from the homepage..

Quote:
Fatal error: Call to undefined function: session_pagestart() in .../modules/Forums/index.php on line 43


I get the following error when I try to access forums from inside of admin area...

Quote:
Fatal error: Call to undefined function: message_die() in .../modules/Forums/admin/pagestart.php on line 60


I searched around a bit and found that such things happen when ppl upgrade forums...but I had used the integrated version in 7.5 and using the same that came with 7.9. I updated the MySQL using the upgrade scripts one by one in order and even checked bbsessions to make sure it has the update.


What am I missing? I'm totally confused amateur Confused
Find all posts by thewallView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Nov 29, 2006 11:34 am Reply with quoteBack to top

Which upgrade did you use? You must use the BBToNuke packages from http://www.nukeresources.com

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
thewall
Nuke Cadet
Nuke Cadet


Joined: Apr 25, 2006
Posts: 4


PostPosted: Wed Nov 29, 2006 12:42 pm Reply with quoteBack to top

Evaders99 wrote:
Which upgrade did you use? You must use the BBToNuke packages from http://www.nukeresources.com


I had installed 7.5 from php-nuke.org download. I didthe same for 7.9
Find all posts by thewallView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Nov 29, 2006 3:51 pm Reply with quoteBack to top

Okay, so you upgraded to phpNuke 7.9. Did you run the upgrade scripts?

Also did you patch it with the latest Patched files?

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
thewall
Nuke Cadet
Nuke Cadet


Joined: Apr 25, 2006
Posts: 4


PostPosted: Thu Nov 30, 2006 9:39 am Reply with quoteBack to top

Evaders99 wrote:
Okay, so you upgraded to phpNuke 7.9. Did you run the upgrade scripts?

Also did you patch it with the latest Patched files?


Update scripts - well, if you are implying the PHP-Nuke update scripts from 7.5 to 7.9, then yes. If you are implying the bbtonuke20x.php found under the forums directory, then No.

Patch - No. I did not attempt that. I want to patch only after I get forums to work.
Find all posts by thewallView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Thu Nov 30, 2006 5:52 pm Reply with quoteBack to top

Generally any errors from FB can be resolved with the Patched files. Given how bad his releases have been, I suggest patching first to see if its already been fixed

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
thewall
Nuke Cadet
Nuke Cadet


Joined: Apr 25, 2006
Posts: 4


PostPosted: Fri Dec 01, 2006 8:25 am Reply with quoteBack to top

Very Happy

Ok...I'll use the patch and try it out.

FYI - I will just patch the forums and see if it works or breaks other areas of the site.
Find all posts by thewallView user's profileSend private message
rubenm
Nuke Cadet
Nuke Cadet


Joined: Aug 05, 2005
Posts: 7


PostPosted: Fri Jan 19, 2007 4:56 am Reply with quoteBack to top

Hi

I am using a Brazil version from " 100 Graus" of PHP Nuke 7.5BR since 2 years or so and i want to change for the new the 7.9 or even 8.0 i wanted to know if it's possible...
Find all posts by rubenmView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Fri Jan 19, 2007 12:30 pm Reply with quoteBack to top

I don't know specifically about that particular version, but if its much like the standard 7.5, you can easily upgrade. Overwrite your files, run the upgrade script.

I don't recommend using any of the latest phpNuke versions. They are a bunch of buggy, untested junk code.
I recommend phpNuke 7.6 + latest Patched files + Sentinel. Or for a more integrated solution, RavenNuke from http://ravenphpscripts.com

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
rubenm
Nuke Cadet
Nuke Cadet


Joined: Aug 05, 2005
Posts: 7


PostPosted: Fri Jan 19, 2007 12:49 pm Reply with quoteBack to top

7.6...ok

at this moment i can upgrad since i dont have space in hosting Razz, i need to delete old stuff first, hte backup is too big...

tanks for the reply
Find all posts by rubenmView user's profileSend private message
moods
Corporal
Corporal


Joined: Dec 13, 2005
Posts: 72


PostPosted: Sat May 12, 2007 11:31 am Reply with quoteBack to top

thewall wrote:
I'm not the OP...but I have an issue with upgrading from 7.5 so I posted in this thread.

I upgraded from 7.5 to 7.9 over the weekend (yeah, who does such a thing on the holiday weekend anyways)...

Everything is working EXCEPT for the forums. I turned on debugging and I get the following error when I access forums from the homepage..

Quote:
Fatal error: Call to undefined function: session_pagestart() in .../modules/Forums/index.php on line 43


I get the following error when I try to access forums from inside of admin area...

Quote:
Fatal error: Call to undefined function: message_die() in .../modules/Forums/admin/pagestart.php on line 60


I searched around a bit and found that such things happen when ppl upgrade forums...but I had used the integrated version in 7.5 and using the same that came with 7.9. I updated the MySQL using the upgrade scripts one by one in order and even checked bbsessions to make sure it has the update.


What am I missing? I'm totally confused amateur Confused


ok wall, can u write how you upgrade step by step? i've lost all my data once, users were wild. so i don't dare to attempt the updgrade till i am 100% sure that i will not lost data Smile
Find all posts by moodsView user's profileSend private message
moods
Corporal
Corporal


Joined: Dec 13, 2005
Posts: 72


PostPosted: Sun Jul 29, 2007 12:59 pm Reply with quoteBack to top

anyone pl Smile
Find all posts by moodsView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Mon Jul 30, 2007 5:05 am Reply with quoteBack to top

Start here: http://www.nukecops.com/PHP-Nuke_upgrade-php-nuke.html

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.178 Seconds - 128 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::