You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 292 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - Have I been hacked? [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
Tyrekicker
Nuke Soldier
Nuke Soldier


Joined: Jun 03, 2003
Posts: 10


PostPosted: Thu Jun 05, 2003 5:29 pm Reply with quoteBack to top

My forums just stopped last night for no reason. I received an error saying:

Code:
phpBB : Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'phpnuke.config' doesn't exist

SELECT * FROM config

Line : 225
File :
/usr/local/psa/home/vhosts/dragraceaustralia.com/httpdocs/modules/Forums/common.php


I thought, no worries, its a database problem, and because I backed up only an hour or two before I would just restore that. But phpmyadmin won't let me submit the sql query for nuke_config table. It looks like this:

Code:
# --------------------------------------------------------
#
# Table structure for table 'nuke_config'
#

CREATE TABLE nuke_config (
   sitename varchar(255) NOT NULL,
   nukeurl varchar(255) NOT NULL,
   site_logo varchar(255) NOT NULL,
   slogan varchar(255) NOT NULL,
   startdate varchar(50) NOT NULL,
   adminmail varchar(255) NOT NULL,
   anonpost tinyint(1) DEFAULT '0' NOT NULL,
   Default_Theme varchar(255) NOT NULL,
   foot1 text NOT NULL,
   foot2 text NOT NULL,
   foot3 text NOT NULL,
   commentlimit int(9) DEFAULT '4096' NOT NULL,
   anonymous varchar(255) NOT NULL,
   minpass tinyint(1) DEFAULT '5' NOT NULL,
   pollcomm tinyint(1) DEFAULT '1' NOT NULL,
   articlecomm tinyint(1) DEFAULT '1' NOT NULL,
   broadcast_msg tinyint(1) DEFAULT '1' NOT NULL,
   my_headlines tinyint(1) DEFAULT '1' NOT NULL,
   top int(3) DEFAULT '10' NOT NULL,
   storyhome int(2) DEFAULT '10' NOT NULL,
   user_news tinyint(1) DEFAULT '1' NOT NULL,
   oldnum int(2) DEFAULT '30' NOT NULL,
   ultramode tinyint(1) DEFAULT '0' NOT NULL,
   banners tinyint(1) DEFAULT '1' NOT NULL,
   backend_title varchar(255) NOT NULL,
   backend_language varchar(10) NOT NULL,
   language varchar(100) NOT NULL,
   locale varchar(10) NOT NULL,
   multilingual tinyint(1) DEFAULT '0' NOT NULL,
   useflags tinyint(1) DEFAULT '0' NOT NULL,
   notify tinyint(1) DEFAULT '0' NOT NULL,
   notify_email varchar(255) NOT NULL,
   notify_subject varchar(255) NOT NULL,
   notify_message varchar(255) NOT NULL,
   notify_from varchar(255) NOT NULL,
   footermsgtxt text NOT NULL,
   email_send tinyint(1) DEFAULT '1' NOT NULL,
   attachmentdir varchar(255) NOT NULL,
   attachments tinyint(1) DEFAULT '0' NOT NULL,
   attachments_view tinyint(1) DEFAULT '0' NOT NULL,
   download_dir varchar(255) NOT NULL,
   defaultpopserver varchar(255) NOT NULL,
   singleaccount tinyint(1) DEFAULT '0' NOT NULL,
   singleaccountname varchar(255) NOT NULL,
   numaccounts tinyint(2) DEFAULT '-1' NOT NULL,
   imgpath varchar(255) NOT NULL,
   filter_forward tinyint(1) DEFAULT '1' NOT NULL,
   moderate tinyint(1) DEFAULT '0' NOT NULL,
   admingraphic tinyint(1) DEFAULT '1' NOT NULL,
   httpref tinyint(1) DEFAULT '1' NOT NULL,
   httprefmax int(5) DEFAULT '1000' NOT NULL,
   CensorMode tinyint(1) DEFAULT '3' NOT NULL,
   CensorReplace varchar(10) NOT NULL,
   copyright text NOT NULL,
   Version_Num varchar(10) NOT NULL,
   KEY foot1 (foot1)
);

#
# Dumping data for table 'nuke_config'
#

INSERT INTO nuke_config VALUES ( 'Drag Race Australia', 'http://www.dragraceaustralia.com', 'logo.gif', 'Australian Drag Racing Community', 'April 2003', 'webmaster@dragraceaustralia.com', '0', 'Aeolus', '', 'All logos and trademarks in this site are property of dragraceaustralia.com. The comments are property of their posters.', '', '4096', 'Anonymous', '5', '1', '1', '1', '1', '5', '5', '1', '30', '0', '1', 'PHP-Nuke Powered Site', 'en-us', 'english', 'en_US', '0', '0', '1', 'webmaster@dragraceaustralia.com', 'NEWS for my site', 'Hey! You got a new submission for your site.', 'submissions', 'Mail sent from WebMail service at - dragraceaustralia.com', '1', 'modules/WebMail/tmp/', '1', '1', 'modules/WebMail/attachments/', '', '0', 'Your account', '5', 'modules/WebMail/images', '1', '1', '1', '1', '1000', '3', '*****', 'Web site engine\'s code is Copyright & 2003 by <a href=\"http://phpnuke.org\" target=\"blank\"><font class=\"footmsg_l\">PHP-Nuke</font></a>. All Rights Reserved. PHP-Nuke is Free Software released under the <a href=\"http://www.gnu.org\" target=\"blank\"><font class=\"footmsg_l\">GNU/GPL license</font></a>.', '6.5');


Apparently there is an error in the 'KEY' line, because the foot1 is a text only, and cannot be indexed. But this is how it came down from the backup??

If I delete this line, it works, but it does not solve my original problem. I get the same forum error. I am using phpnuke 6.5. I have been up all night trying to solve it, but to no avail.

Any ideas? I am running around like a headless chicken over this.
Thankyou in advance.
Adam Hennessy


Last edited by Tyrekicker on Thu Jun 05, 2003 5:34 pm; edited 1 time in total
Find all posts by TyrekickerView user's profileSend private message
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Thu Jun 05, 2003 5:32 pm Reply with quoteBack to top

That schema is NOT what comes with nuke 6.5. There is no key on the config. There's only 1 record; you don't need one.

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Thu Jun 05, 2003 5:36 pm Reply with quoteBack to top

Did you try installing any modules or blocks that maybe issued an ALTER statement?

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
Tyrekicker
Nuke Soldier
Nuke Soldier


Joined: Jun 03, 2003
Posts: 10


PostPosted: Thu Jun 05, 2003 5:43 pm Reply with quoteBack to top

Thanks for your help. I checked a few pages, and my page_header.php was corrupt. I don't know how someone could have had a go at that though. But it was all over the place.

I just uploaded it again and voila! it is all fine. (PHEW!)

Now to go to bed. Thanks for setting off the right alarm bells in my head to get this thing sorted.
Find all posts by TyrekickerView user's profileSend private message
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Thu Jun 05, 2003 5:44 pm Reply with quoteBack to top

Well, what I told you is still true. That schema is not correct Wink

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
crashoverride



Joined: Jan 31, 2004
Posts: 0


PostPosted: Fri Jun 06, 2003 2:58 am Reply with quoteBack to top

also, the config table is a nuke table, not a forum table. bbconfig is the forum config table

CO
Find all posts by crashoverrideView user's profileSend private message
Tyrekicker
Nuke Soldier
Nuke Soldier


Joined: Jun 03, 2003
Posts: 10


PostPosted: Sat Jun 07, 2003 1:00 pm Reply with quoteBack to top

Well it seems to be working now. I editted out the KEY index at the bottom, but I have noticed that a lot of my tables have a similar reference at the bottom. Why would they have been placed there if they weren't needed?

And yeah, i realise the config table is a nuke table, that was the problem with the page_header.php. It was looking for a whole lot of stuff that didn't exist.

Thanks for you assistance though guys. Cheers.
Find all posts by TyrekickerView user's profileSend private message
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Sat Jun 07, 2003 1:06 pm Reply with quoteBack to top

They may have been modified by another script, who knows?

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.157 Seconds - 428 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::