You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 272 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - config.php related to phpbb port? [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
Northsea
Nuke Cadet
Nuke Cadet


Joined: Jun 20, 2003
Posts: 6


PostPosted: Fri Jun 20, 2003 12:37 pm Reply with quoteBack to top

Hi!

I have a strange problem.
According to the installation of phpnuke, it's recommended to move the real config.php out from the /html directory (server root), and replace the config.php with one that import's it from some other place, that's not the server root. For example:

<?php include("../config.php"); ?>

However, when doing so, i can't administer phpbb, because i get this error:

Warning: Failed opening '../config.php' for inclusion (include_path='.:/usr/share/php/PEAR') in /path_to_phpnuke/html/config.php on line 1

Fatal error: Cannot instantiate non-existent class: sql_db in /path_to_phpnuke/html/db/db.php on line 86

I'm using phpnuke 6.5 final, and the phpbb port that's included with that release (haven't upgraded phpbb port because to tell you the truth i don't know wich upgrade to pick?)

Thanks in advance

/Northsea
Find all posts by NorthseaView user's profileSend private messageMSN MessengerICQ Number
mikem
Theme Guru
Theme Guru


Joined: Jan 13, 2003
Posts: 1582

Location: Corn fields of Indiana

PostPosted: Fri Jun 20, 2003 1:06 pm Reply with quoteBack to top

Hello and welcome.
Actually, if you are using NUke6.5 final, then you are running the latest release of the phpBB port in your Nuke. Analyzer may be reporting an older version but that just needs changed in the Database.
_bbconfig table, change version from .0.2 to .0.4

As for the config.php not in the Nuke root. Yes it is recommended to remove it but not absolutely necessary.
I'm not sure what the problem is there with moving it, unless it has something to do with phpBB's config.php file and the path.

mikem

_________________
Getting Started | My Projects
Find all posts by mikemView user's profileSend private message
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.070 Seconds - 455 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::