You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 293 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - Validate Links (7.3) - Not Working [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
new2nuke
Nuke Cadet
Nuke Cadet


Joined: Dec 20, 2003
Posts: 2


PostPosted: Tue Aug 10, 2004 7:08 am Reply with quoteBack to top

When validating the web links, they all fail. However, when checking some of them manually they are correct and should pass.

I'm using PHPNuke 7.3.

Also, it looks like there’s some minor errors in the code (admin/modules/links.php):

Quote:
$result = $db->sql_query("SELECT lid, title, url, name, email, submitter from " . $prefix . "_links_links order by title");
}
/* Check Categories & Subcategories */
if ($cid!=0 && $sid==0) {
echo "<tr><td colspan=\"3\"><center><b>" . _VALIDATINGCAT . ": $transfertitle</b><br>" . _BEPATIENT . "</center><br><br></td></tr>";
$result2 = $db->sql_query("SELECT lid, title, url, name, email, submitter from " . $prefix . "_links_links where cid='$cid' order by title");
}
/* Check Only Subcategory */
if ($cid==0 && $sid!=0) {
echo "<tr><td colspan=\"3\"><center><b>" . _VALIDATINGSUBCAT . ": $transfertitle</b><br>" . _BEPATIENT . "</center><br><br></td></tr>";
$result3 = $db->sql_query("SELECT lid, title, url, name, email, submitter from " . $prefix . "_links_links where sid='$sid' order by title");
}
echo "<tr><td bgcolor=\"$bgcolor2\" align=\"center\"><b>" . _STATUS . "</b></td><td bgcolor=\"$bgcolor2\" width=\"100%\"><b>" . _LINKTITLE . "</b></td><td bgcolor=\"$bgcolor2\" align=\"center\"><b>" . _FUNCTIONS . "</b></td></tr>";
while($row3 = $db->sql_fetchrow($result3)) {


Shouldn't the result statements above all be "$result", not "$result2" or "$result3"? And "sql_fetchrow($result3)" should therefore be "sql_fetchrow($result)"?

Also, when the results from checking the links are displayed, the URLs are incorrect:

Quote:
."<td>&nbsp;&nbsp;<a href=\"$url\" target=\"new\">$title</a>&nbsp;&nbsp;</td>"


The above causes all the links to point to my own URL.

Anyone else experiencing problems? Or has this already been fixed in 7.4?
Thanks.


Last edited by new2nuke on Wed Aug 11, 2004 3:01 am; edited 1 time in total
Find all posts by new2nukeView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Tue Aug 10, 2004 8:36 pm Reply with quoteBack to top

$result2, $result3 are both valid. They are used to distinguish between different SQL query commands so that bug fixes can be applied to the correct lines.

Perhaps check the Patched files and see whether this is corrected. http://www.nukefixes.com

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
new2nuke
Nuke Cadet
Nuke Cadet


Joined: Dec 20, 2003
Posts: 2


PostPosted: Wed Aug 11, 2004 2:58 am Reply with quoteBack to top

I have already applied the patched files.

If $result2 and $result3 are used, shouldn't the while statement be changed? At the moment rows can't be fetched from $result or $result2, only from $result3.
Find all posts by new2nukeView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Aug 11, 2004 5:50 pm Reply with quoteBack to top

I guess there is a problem then. I don't know why they are retrieving those rows.

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.228 Seconds - 240 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::