You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 153 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - -help- Security Image Disappeared [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Sat Jun 12, 2004 11:09 pm Reply with quoteBack to top

My secuirty Code Image suddenly disappeared.
I had a problem getting in my Admin a minute ago.
I got in but I just notied my Security code is gone
Something fishy going on?
Please help - this would be very depressing getting hacked as it took me 4 months to get the site ALMOST error free ;(

Update: I checked my tables in my sql and I had installed NSN Your Account the other day to clear up some issues with my account module (it was a mess) but now I go in USERS and it says next to SECURITY CODE GDLib not installed I check my sql table and usegfxcheck = 0... nothing happenns if I change it to 1 Sad

I dont get it. I'm having aterrible day.

I swear I this happenned JUST NOW and I had the nsn your account inside the nuke for at least a few days and I had no problem making a secirity image with the old Your Account
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
NukeFanatic
Sergeant
Sergeant


Joined: May 20, 2004
Posts: 89


PostPosted: Sat Jun 12, 2004 11:48 pm Reply with quoteBack to top

Ill try to help. a few questions:
1) what version of nuke/php/sql
2) any funny business in you "nuke_authors" table
3) you have backups, right?
4) i assume this is a hosted nuke install - correct?
5) Is your gd library installed - check phpstat() - look for "GD Support enabled"
6) You have installed security scripts - right?
7) "my account module -it was a mess" - this does not sound good!
good luck.
don
Find all posts by NukeFanaticView user's profileSend private message
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Sun Jun 13, 2004 12:08 am Reply with quoteBack to top

Very Happy THANK YOU

Ill try to help. a few questions:
1) 7.3 w/ patches - PHP 4.3.3 - My SQL 4.0.18-standard
2) Nothing Appears Funny
3) Backups of What? I have Backups of what I have Now but I don't have backups of what I had before because what I have now seemed to work until Just now. However I have placed the backup over the live version since the error occurred (I thought something fumbled) but it didn't do anything to help remedy it. It all worked just fine just a few minutes ago.
4) I pay for the host but it is on a subdomain so yes I supposse
5) I don't know how to do this
6) Protecter so far. I haven't gotten to the others yet.
7) It was the original Nuke 7.3 then the patches then the update then the protecter ... the only real problem was it wasn;t sending out user activation emails and It wasn;t letting me disable the email sending. I made a post about it on several forums but no one answered it. Finally I was sugggested to use NSN My Account so that I can shut off the whole activation thing all together.. which solved things - However now I have this problemm - which I'm not sure is relevent, however just as annoying and just as scarey.


My admin.php wouldn;t let me in a moment ago but it was because I typed the admin god name wrong and it said to be BEGONE! and then I was stuck I was panicing! But then I found a post and I was able to get in and login correctly whic solved that BUT it was DIRECTLY after this problem that the security images stopped working.

OH WOE IS ME!
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
NukeFanatic
Sergeant
Sergeant


Joined: May 20, 2004
Posts: 89


PostPosted: Sun Jun 13, 2004 12:27 am Reply with quoteBack to top

create a file called info.php - in this file put the followin code:
Code:

<?php
phpinfo();
?>

upload the page to your hosted subdomain and run it
scroll down the page untill you find GD and see if it is "enabled" or "disabaled"

if it is enabled then there is a different problem - maby in the your_account\index.php
if it is disabled then your host needs to enable it....

don
Find all posts by NukeFanaticView user's profileSend private message
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Sun Jun 13, 2004 1:05 am Reply with quoteBack to top

nothing says GD at all?!

not near it either.

I assure the image worked a few hours ago. Oh this is like some phantom dissappearing image Evil or Very Mad
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
NukeFanatic
Sergeant
Sergeant


Joined: May 20, 2004
Posts: 89


PostPosted: Sun Jun 13, 2004 2:01 am Reply with quoteBack to top

hmm - no GD at all....
well, have you looked at:
http://www.nukecops.com/postt747.html
I'd be happy to dive into the guts of GD with you tomorow as it is very late here

Can you perhaps copy your nuke system local to make debugging more easy.
go to
http://www.reactorserver.com/
or
http://www.apachefriends.org/en/index.html
or install apache/php/mysql/nuke manually

don
Find all posts by NukeFanaticView user's profileSend private message
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Sun Jun 13, 2004 3:01 pm Reply with quoteBack to top

OHHHH I wasn't sure what you meant by hosted. I do not own my server I am on I lease a portion as a shared server from a hosting company I found online. I was thinking of installing an exact copy of my forum on another server just so I can show some people the guts. If you talking about copying my LIVE Nuke to my Home PC I can do that because I have PHP Triad. However I have a problem on my home server with some of the Nuke because the forums has errors on my windows unix emulator (cannot redifine headers) it came like that straight off of the nuke.org site so thought it was just something that happens with Windows. So which would you have me do...

A) Put the site back on my local machine

B) make a copy of my site on another server


^^^ Let me know
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
madman
Support Mod
Support Mod


Joined: Feb 15, 2004
Posts: 806


PostPosted: Sun Jun 13, 2004 3:20 pm Reply with quoteBack to top

Then you can't gain access to PHP configuration if you've just hosted. Ask to hosting company whether they plan to put GD extension to their PHP engine. The only way to find out whenever your server support GD extension is through phpinfo() as describes above.

If you use free hosting service, all you can do is disable security code for admin/user login and install any nuke security scripts.

There also some alternatives instead phptriad, like foxserv that will be running under windoz without emulator (but you'll need separated mail server product). If your PHP running perfectly in your windoz, you can enable GD extension by editing php.ini (either in windoz directory or Apache directory) and enable some extensions available there (including GD).

_________________
I'm Image
Find all posts by madmanView user's profileSend private messageVisit poster's websiteYahoo MessengerMSN Messenger
NukeFanatic
Sergeant
Sergeant


Joined: May 20, 2004
Posts: 89


PostPosted: Sun Jun 13, 2004 5:54 pm Reply with quoteBack to top

i found some fun code over @ php.net - try uploading this to your host:
Code:

<?php

echo "<hr>\n";

if (extension_loaded("gd")) {
   echo "GD is loaded";
} else {
   echo "GD is NOT loaded<br>\n";
}

echo "<hr>\n";

if (!dl('gd.so')) {
   echo "GD could NOT be loaded<br>\n";
} else {
   echo "No attempt was made to load GD<br>\n";
}

echo "<hr>\n";

$aGD  = gd_info();
$nArr = array_keys($aGD);
echo $nArr[0] . " = " . $aGD[$nArr[0]] . "<br>\n";
for ($iCnt = 1; $iCnt < count($nArr); $iCnt++) {
   if($aGD[$nArr[$iCnt]]) $bool = "Y"; else $bool = "N";
   echo $nArr[$iCnt] . " = " . $bool . "<br>\n";
}

echo "<hr>\n";

?>


All this prog does is
1) check to see if GD is loaded
2) Tries to load it manually
3) displays some info about GD

Here is what it said on my test system:
Code:

-------------------------------------------------------------------------------
GD is loaded
-------------------------------------------------------------------------------
Warning: dl(): Not supported in multithreaded Web servers - use extension statements in your php.ini in C:\Reactor\htdocs\nuke\_gd.php on line 13
GD could NOT be loaded
-------------------------------------------------------------------------------
GD Version = bundled (2.0.15 compatible)
FreeType Support = Y
FreeType Linkage = Y
T1Lib Support = N
GIF Read Support = Y
GIF Create Support = N
JPG Support = Y
PNG Support = Y
WBMP Support = Y
XBM Support = Y
JIS-mapped Japanese Font Support = N
-------------------------------------------------------------------------------



As to the "(cannot redifine headers)" problem on you windows/unix emulator:
try seting output_buffering = on in php.ini <-- fixes problems like this

As to copying you site - copies are good for testing
and for backups when bad things happen (hack/corruption)

If you can copy to another server - the new server may have GD installed.

don
Find all posts by NukeFanaticView user's profileSend private message
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Sun Jun 13, 2004 6:22 pm Reply with quoteBack to top

I tried that file and it said

Code:
GD is NOT loaded

--------------------------------------------------------------------------------

Warning: dl(): Unable to load dynamic library './gd.so' - ./gd.so: cannot open shared object file: No such file or directory in /home/solitary/public_html/gd.php on line 13
GD could NOT be loaded

--------------------------------------------------------------------------------

Fatal error: Call to undefined function: gd_info() in /home/solitary/public_html/gd.php on line 21



Quote:
As to the "(cannot redifine headers)" problem on you windows/unix emulator:
try seting output_buffering = on in php.ini <-- fixes problems like this


How do I do this? I think I have php.ini so what do I add to this - do you know how to do this or is it different for each one? I struggled with PHP Triad to get it working LOL when I first installed it I had to have my friend take controll of my machine with the network and configure it it was CONFUSING! is that fox one easy to install? Does it come with PHPmyadmin? What do you mean I need a mail server? I'm going to go look at it, Meanwhile I suppose I have mail to send to my host.

NukeFanatic do you have a website Very Happy
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
thewizard
Sergeant
Sergeant


Joined: Sep 01, 2003
Posts: 134

Location: Germany

PostPosted: Sun Jun 13, 2004 8:47 pm Reply with quoteBack to top

hi there. as for your output_buffering well just look within your php.ini for a line reading output_buffering = . after = maybe there is off or on or maybe 4096. if it runs
output_buffering = off, so just delete "off" and write "on" instead, if the line runs
;output_buffering = ON (or maybe 4096) so just remove the";"

for the gd-thing, well if it worked correctly and stopped it within a minute, i also think its a matter of your hosting company

_________________

Rather must you Become, and Become, and Become, until Hackers respect thy Power, and other Wizards hail thee as a Brother or Sister in Wisdom, and you wake up and realize that the Mantle hath lain unknown upon thy Shoulders since you knew not when.
Find all posts by thewizardView user's profileSend private messageVisit poster's website
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Mon Jun 14, 2004 10:11 am Reply with quoteBack to top

I emailed my hosting company and they said "GD Library has been re-added to php" so I go and look and NO IT HASNT...lol
The only difference I saw was in the phpInfo file I saw

Code:
HTTP_ACCEPT_ENCODING  gzip, deflate
Accept-Encoding  gzip, deflate
_SERVER["HTTP_ACCEPT_ENCODING"] gzip, deflate


Otherwise nothing about GD and the gd.php file has the exact same error. What should I tell them?
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
thewizard
Sergeant
Sergeant


Joined: Sep 01, 2003
Posts: 134

Location: Germany

PostPosted: Mon Jun 14, 2004 10:50 am Reply with quoteBack to top

hmm, well i dont hope they forgot to restart their apache Shocked , well if i where you i would sent them the output of the gd.php you used and ask them to verify that....
but btw what company is that? if you would tell maybe some people around here use the same hosting company and can tell 'bout their gd

_________________

Rather must you Become, and Become, and Become, until Hackers respect thy Power, and other Wizards hail thee as a Brother or Sister in Wisdom, and you wake up and realize that the Mantle hath lain unknown upon thy Shoulders since you knew not when.
Find all posts by thewizardView user's profileSend private messageVisit poster's website
kyomii
Corporal
Corporal


Joined: Nov 12, 2003
Posts: 66


PostPosted: Mon Jun 14, 2004 12:58 pm Reply with quoteBack to top

ehostdepot.com
or
webhostingweb.net
Find all posts by kyomiiView user's profileSend private messageSend e-mailAIM Address
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.227 Seconds - 335 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::